Google Flights Doesn’t Support Google Crawler

Last night I wanted to check out Google Flights on my iPhone so I did a quick Google search. I was surprised to see the search result description:

We have detected that you are using an unsupported web browser. We support Firefox 3.5 or later, Chrome, Safari 4 or later, or Internet …

You’d think step one of building any new site at Google would be to make it work with their own crawlers.